Petfinder is experiencing delays processing updates
Incident Report for RescueGroups.org
Resolved
We believe that Petfinder has addressed the delays involving their import system. We will continue to monitor exports closely and communicate with Petfinder if we notice any related issues. If you experience delayed updating of your Petfinder account (more than 3 hours), please contact our support team to let us know.
Posted Jun 07, 2022 - 08:18 EDT
Identified
Petfinder has reported that their import system is operating slower than normal, and they are working to address the issue. We currently have reports of uploads taking multiple days to process. Once they resolve the issue, Petfinder expects updates to return to the normal processing time of an hour or two. We will update this incident as we learn more.
Posted Jun 01, 2022 - 13:58 EDT
Investigating
We received several reports regarding delays in updates to Petfinder accounts over the weekend. We've confirmed that RescueGroups.org is uploading data to Petfinder as expected, but it is not being processed by Petfinder in the normal timeframe. We have reached out to Petfinder regarding this issue and will update this incident when we have more information.
Posted May 31, 2022 - 23:11 EDT
This incident affected: Exports to Petfinder.