Petfinder site experiencing delayed animal listing updates
Incident Report for RescueGroups.org
Resolved
We believe this issue has been fully resolved and Petfinder is processing updates as expected. Please contact our support team (support@rescuegroups.org) if your Petfinder account is still displaying out of date or missing animals.
Posted Jan 24, 2023 - 11:06 EST
Update
Petfinder has posted that the issue they encountered has been resolved. We are seeing that our uploads are being accepted now, but do notice some Petfinder accounts are still not displaying updated animals so there may be some delays as Petfinder's system catches up. We will continue to monitor the situation and work with Petfinder to ensure accounts are updating as expected.
Posted Jan 19, 2023 - 17:23 EST
Update
Petfinder's system is currently preventing the upload of animal data. Petfinder is aware of the issue and working on it:
https://help.petfinder.com/s/article/01-17-23-Auto-Import-Issue

We will update this incident when we have more information.
Posted Jan 18, 2023 - 09:08 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 18, 2023 - 09:06 EST
Monitoring
We believe Petfinder has addressed this issue, and will continue monitoring to ensure the service is operating as expected.
Posted Nov 25, 2022 - 11:01 EST
Update
Petfinder has provided more information about the duplicated animal records issue on their website here:
https://help.petfinder.com/s/article/09-27-22-Auto-Import-Issues
Posted Sep 29, 2022 - 15:27 EDT
Identified
We've received reports from a few organizations that some animal records are being duplicated when uploaded to Petfinder in the last two days. We've confirmed that our data upload is operating normally and does not contain duplicate information. We have reached out to Petfinder about this issue. We will update this incident when we have more information from Petfinder.
Posted Sep 28, 2022 - 17:37 EDT
Monitoring
We have received confirmation from Petfinder that their import system was operating slower than normal over the last few days but once the issue is resolved, they expect uploads to go back to normal processing time. There's no further action needed by our organizations other than to continue uploading animal data as they normally do.

We noticed several of our organization's Petfinder accounts have updated yesterday and today, which is certainly an improvement. We will continue to monitor on our end and update this incident when we believe it is fully resolved.
Posted Sep 07, 2022 - 09:54 EDT
Investigating
We are receiving reports from our organizations regarding delays in updates to Petfinder accounts this weekend. We've confirmed that RescueGroups.org is uploading data to Petfinder as expected, but these updates not being processed by Petfinder in the expected timeframe. We have reached out to Petfinder regarding this issue and will update this incident when we have more information.
Posted Sep 04, 2022 - 15:26 EDT
This incident affected: Exports to Petfinder.