Several RescueGroups.org services experiencing delays or outages

Incident Report for RescueGroups.org

Monitoring

Our team has been working hard to address this situation. While it has been resolved at this time, we are still implementing some improvements related to the issue to improve our services in the future.
Posted Jul 06, 2026 - 09:44 EDT

Investigating

We are currently investigating this issue.
Posted Jul 01, 2026 - 15:07 EDT
This incident affects: RescueGroups.org website, API v2, Support Website / system, and API v5.