Email and Web Hosting services experiencing delays
Incident Report for RescueGroups.org
Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 11:25 EST
Update
We wanted to provide an update and let our users know that although we have been removed from blacklists, some third party email servers are still choosing not to accept emails from our hosting service. This is due to our reputation being affected by the original incident. We have been working to repair our reputation as much as possible, and expect the situation to resolve soon.
Posted Feb 10, 2020 - 13:39 EST
Monitoring
Unfortunately, we experienced a spam issue with an Email Hosting user. Our email server has been temporarily blacklisted due to this incident but should be removed soon now that the issue has been resolved. Please note, emails are being received, but emails sent may not be delivered until we are removed from the blacklist. We regret the inconvenience. Please contact our support team (support@rescuegroups.org) if you need additional assistance.
Posted Feb 04, 2020 - 11:55 EST
Investigating
Our Email and Web Hosting services are experiencing delays at this time. We are investigating the issue and will have more information shortly.
Posted Feb 03, 2020 - 20:08 EST
This incident affected: Email and Web Hosting.