FTP accounts experiencing intermittent issues
Incident Report for RescueGroups.org
Resolved
We believe this issue has been resolved. If you are still encountering any issues with importing data to RescueGroups.org please let us know by contacting our support team.
Posted Mar 04, 2023 - 16:03 EST
Investigating
We are currently investigating the issue and working towards a resolution.
Posted Feb 24, 2023 - 07:22 EST
This incident affected: FTP Accounts.